Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Readout flickers with motor running (glass scales)
I just finished installing 1um glass scales on my 6x12 surface grinder. Unfortunately, there was no good place to install the Z-axis scale, other than right next to the motor. The motor itself is a 3/4hp 3-phase, 220V unit, running off a VFD.

The reading is dead stable with the VFD powered up, but once the motor is up and running, the 4th decimal flickers 1-4 tenths. On a mill or lathe, this wouldn't be a concern... But on the surface grinder, tenths matter.

Is there any way to shield the scale, or otherwise eliminate noise? I've read that the iGaging scales benefit from a 0.01uF cap soldered from VCC to GND... Is there something similar that can be done on the glass scales?

Any help would be greatly appreciated.
YouTube: FnA-Wright Engineering
I have never seen this happen with glass scales. I don't even know what the mechanism would be that can cause this behavior. I.e. based on how the glass scales are implemented, there should be no way for the encoder to do this. If this is line noise, it would be at most one encoder tick going up and down (1 micron is approximately 0.00004") so 1-4 tenths is up to 10 microns. Does the DRO drift over time, or is it just going up and down?
What type of TouchDRO adapter are you using?
Can you post a picture of your wiring and the scale?
It doesn't seem to drift. The flicker starts wn the motor is about halfway spooled up, and gets worse until it reaches full speed. I'm using the latest glass scale adapter, purchased a month or 2 ago.

I suppose it could just be a faulty scale. I tried running a wire from a mounting pad on the adapter, to the machine, thinking maybe it was a ground issue, and noticed the adapter shut off when I touched the wire to the machine. Somehow I was getting 5v between that wire and the machine frame. I troubleshot this to a tiny solder bridge under the tiny ribbon cable in the read head itself. I removed the solder bridge, and that fixed the weird voltage/grounding issue, but the flicker persists.

I'm at work, I'll post pictures and a video when I get home in the morning.
YouTube: FnA-Wright Engineering
Ok... Here's a link to a quick video, demonstrating the issue. The TouchDRO adapter is plugged into an outlet that turns on with the main power switch. I have also tried plugging it into a different outlet, with a different USB power supply, as far away as the scale cables would allow, with the same result.

I didn't notice before, how both readouts drift down and settle like they do in the video, when the tablet first connects. Not sure if it's always done that.

The flicker is the same before, and after the solder bridge issue mentioned in my previous post.

Also, you can see the Z-axis readout flicker getting worse as the motor comes up to speed, but as soon as I press the button to turn the motor off, the readout is rock solid. Looks like the Y readout flickers once or twice right after I hit the button to start the motor, but otherwise stays solid.

The motor itself is a Kingston Conley, 3/4hp, 3450RPM, 220V 60Hz 3-phase unit from sometime in the 1930's to mid-1940's. I brought it to a local electric motor shop when I first bought the surface grinder, and they gave it a clean bill of health.

The VFD is a Lapond SVD-ES 1ph input, 3ph output unit. Cheap import.

The scales themselves are the usual generic glass scales sold by any number of resellers on eBay.

That's all the info I can think to provide. Let me know if you need more.

And here's pictures:

These 2 show how close the scale is to the motor.

[Image: obE3P8U.jpeg]
[Image: C11pZIg.jpeg]

Next, this is the current setup. I know it's a mess... I'll eventually put the adapter in an enclosure, and make everything nice and tidy. This is just for the testing phase. Separating all the cables and such had no effect.
[Image: j8h28OE.jpeg]

Next is the connector. The scale pinout is 1=+5v, 2=0V, 3=A, 4=B. They're each connected to the appropriate pin on the adapter connector.
[Image: cFIqtEi.jpeg]

Finally, the adapter itself. The ring terminal wire is connected to the chassis of the machine.
[Image: 9GtsyVM.jpeg]
YouTube: FnA-Wright Engineering
Try replacing the vibration dampening motor mounts or adding them if it doesn't have any.
I had a similar issue on my old Clausing mill some years back and replacing them did the trick.
One place to source them is McMaster-Carr:
It's difficult to tell from the video, but it seems I detect a small amount of vibration that can cause this. The mounts are inexpensive and would be a good place to start your troubleshooting.
I have 13 different glass scales that are not mounted on my machines. I tried messing with each of them (including removing the metallic shroud and wrapping it around 1HP 3-phase motor on three different VFDs (two AlenBradleys and one cheap Chinese VFD). I can't reproduce this. Even in the worst case scenario I see only small ripple on the scope.

This sort of flickering can happen only if bot lines (A and B) have pulses that can be interpreted by the decoder. Noise on a single line would flicker up and down by 1 micron. The ripple would need to be over 1V at least. I didn't think about mechanical vibrations until Jimy mentioned the dampers. The scale is awfully close to the motor but this is a surface grinder, so I'd imaging vibrations would be pretty low. If it's not a lot of work, can you try removing the scale and see if there is any drift when't it sitting on the chuck, for example, when you turn on the motor?

I have these glass scales on my Lathe saddle, rock steady until moving the saddle with the handwheel and the driven gear hits the 2 teeth missing on the spur gear creates a thud and the display jumps, does the same in both directions. With the saddle in machine feed there is no thud as the missing teeth are not in the machine feed drive and no display jumps.
Yeah, it's a mechanical issue. No idea how old the belt is, but the machine definitely sat unused long enough before I bought it, that the belt took on an oval set. I could feel it when I turned the grinding wheel by hand, and it was causing ripples in the finish when I started grinding in the mag chuck. The belt was going to be the next thing I replaced after I got the scales installed and working...

Took the belt off, fired up the motor, and the display is rock solid. Ordering a new belt asap.

Thanks for all the help, peoples. Especially Yuriy... Thanks for doing so much testing on your own, to help me solve this. Would've taken me a lot more time and frustration to figure out, without all the input.
YouTube: FnA-Wright Engineering
So, to follow up with this... I replaced the belt with one of those link-belts. Fired it up, and the readout for both axes was rock-solid.

Thanks again for all the help.
YouTube: FnA-Wright Engineering
Hi, I'm glad that everything worked out for you.

Forum Jump:

Users browsing this thread: 1 Guest(s)