Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help Please
Hi there
I would like some help please I have a mill  I fitted with M-Sure scales bought from M-DRO here is a link to one of them.
I would like to build my own Touch DRO and have purchased thre following.
MSP430 Launchpad.
HC05 Bluetooth module
3 USB breakout boards
I have downloaded the MSP430 Firmware for iGaging Scales v 2.00
and have written it to the MSP430
I have wired the board as follows
USB breakout boards D- to 1.7
                                  D+ to 2.3/2.4/2.5
Bluetooth VCC to 5Volts
Bluetooth GND to gnd
Bluetooth RX to 1.2 (TX)
using the USB connector of the computer to give me power to the board I have given the USB breakouts and the Bluetooth a feed of 3.3 volts from the MSP430
I dont seem to be able to insert a picture of the wiring diagram sorry.

I can connect the Bluetooth to my android tablet. and it seems to be happy but if I move the scales nothing happens on the display. What am I missing ?
Do I have the correct Firmware for the scales I am using ?
Have I wired it correctly ?
Do I have to setup something in the App?
Can someone help please.
The most up-to-date info is here:
It looks like you are trying to build the old iGaging "basic" adapter and use it with Shahe scales. That won't work.
So i am using the wrong software i am using igaging v2.0 is this wrong for this type of scale?

just updated the firmware to v2.04 still no joy.
I am using a MSP430 G2ET board with a MSP430G2553 chip
I have installed on the tablet an App called bluetooth terminal and when I reset the MSP430 the app tells me I am running Universal V2.4 and is copyrighted to Yuri. and then I get x0,x0,x0,etc.
If I upload the mixed scaleV1.0 then i get x0,y0,z0,w0, ect but still nothing when I move the scales.
moving the scales does nothing and if i start up the dro app the scales read 0.000and do nothing when I move them Has anyone had this problem ?
I am completly lost here.
Hi Redpiperbob,

If I read your post correctly, I think using pin 1.7 is at least part of your problem.

The more recent firmware does not use a common clock and should be wired to this later configuration:

As well as using individual clock pins per scale, you should note the W axis data line has moved.

Also worth noting, that if you're looking for it, the clock signal will not be present on the clock lines unless there was a scale connected when the Launch Pad was reset/powered on, (part of the auto scale detect I suspect).

Hope this helps.
Hi Norman
Thanks for that I will give that a try.
Can you tell me the firmware I should use with these scales
I was going to use the Mixed ie digitalReadout_Universal_V1.0.txt
Is this the correct one ?

OK just tried the wiring as the link you sent still no joy.
On the tablet if I look at the bluetooth then I get the x0,y0,z0,w0, but altering the scales does nothing in the dro app.

OK progressI found an old scale in the bottom of the draw and if I fit it to the adapter the app works So I guess the scales I have will not work with the adapter boards.
can someone in the UK point me to scales that will work with the MSP430 ?

Those scales are rebadged and not made by, they are probably Shahe but only would know and what version, you could ask but doubt they would want to give out commercially sensitive info.
Kommando I asked them and they said they didnot know. all I know mis I cannot get them to work.
I have tried other old ones I have and have got two working in a roundabout way i guess I need to buy a third for the Z but I dont know which one to go for I might try  the Arceurotrade ones but they look the same.
Hi Redpiperbob,

I'm using arceuro scales that i bought from them about a year ago so hopefully they are still selling the same version. The ones I have work ok apart from the known jumping issue Yuriy describes at this link:

Good luck,

Forum Jump:

Users browsing this thread: 1 Guest(s)