Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DRO - Dropping Values (inaccurate reading of scales)
#1
Hello Forum (and hopefully Yuriy)

I have a Touch DRO board connected to AccuRemote Stainless steel scales and read on a Kindle Fire tablet. A link to my build below speaks to the vintage (2018) and some of the details. 

https://forum.yuriystoys.com/showthread....t=millrite

The issue I am having is the system is either stalling or misreading and my location/measurement is off. It will not just go back to zero but will be off along a move and mess up where I want to finish the cut. 

I was happening to my Z (on the quill) which I was able to work around because I don't often repeat movements in Z but now it is happening to X wich is more trouble than it is worth and have gone back to reading dials just in case. 

I tried isolating the scales from the machine with plastic washers and so that they aren't grounded to the machine and it hasn't helped. I've also tried shutting down all Bluetooth (I usually listen to music near by with a BT speaker and my phone) and this didn't help either. 

Does anyone have experience with this? A fix? Do the boards have a shelf life? Is there a new version of the software coming that could help? Should I order a new board? Can it be my scales?

I know that's a lot to ask but any help would be very helpful.

I hope all is well with everyone. 

Thank you in advance, 
_Mike
Reply
#2
Mike,
This is very likely a scale issue. The board doesn't keep track of the position; it gets it from the scale "fresh".
Try moving the scales between the inputs and see if the problem follows the scale if this is a scale issue. It will stay with the same input if this is a board issue.
The board you have has a "shelf life" due to the electrolytic capacitors, but unless you are using it in 120F heat every day, the shelf life for the Panasonic caps should be a few decades, not three years.
If you have the means to reprogram the board, you might try the latest firmware. I've tweaked the timing a bit a few versions ago to make some older scales a bit more stable. I doubt it will help since your scale seemed to work before, but it's worth a try.
I recently posted a bunch of updates to the Troubleshooting section on the site. Take a look here if you haven't: https://www.touchdro.com/resources/troub...oting.html
Reply
#3
Yuriy,

Thank you for the reply! I will try and swap the scales and hopefully isolate the issue to the scales. I'm not excited about getting new scales if that is the case. If it is do you have a recommendation for scales that will work with the board that I have?

I don't know how to reprogram the board and fear I will make it worse. I've read instructions that include downloading software from TI and then using the latest firmware file (.txt) but am unsure about how to connect the board to the computer. I didn't know if there was an intermediate component that should be used. If you are able to walk me through it I am willing to give it a try.

Thanks again!!!

_Mike
Reply
#4
Yuriy,

Thank you for the link to troubleshooting!


I swapped the scales on the adapter and I couldn't recreate the error. Then I swapped them back and still couldn't. Note that the machine was not running at this point. 

Based on your troubleshooting, I'm going to check the grounding, look into a different power supply, and try it with the motor on. This is mounted to a machine that has a 3 phase motor connected to a rotary phase converter that is very close to the machine. I suspect there is quite a bit of noise present. 

I'll keep digging and report back if you are interested. 

Thanks, 
_Mike
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)