Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
X axis not working correctly
#22
(02-27-2018, 02:30 AM)Yuriy Wrote:
(02-26-2018, 11:26 PM)Philcobt Wrote: Hi Yuriy

I have a similar problem to the above using scales from Machine DRO (UK) using the Do-it-yourself DRO Mixed Scale Controller Kit. I have changed the MSP430, put each scale in the various X, Y & Z inputs, all with no improvement. The Y axis seems most jittery, jumping from 0.00mm to 10403mm (0 to 409inch) and back again, but all axis jump in this way. They all revert to the same base number after jumping up to 10,000+mm.
I have checked all soldered joints and all seem OK.
Is there any thing else I can try or is it a Bin6 conversion problem that I read somewhere?
Is there an update on the code due soon please?
Regards,
Barry (UK)

I'm out of town till next Friday, so I can't look into this right now, but can you post the link to the exact scales you have?

Thanks for the rapid reply.
 
The scales I have are a few years old and worked without problem on my mini mill with a YADRO system ( YADRO is a 4 channel PC interface (DOS) which will take Chinese scale input and output via a serial link to a PC) and I wanted to update it with your system using a Hudl 2 tablet with Android 5.1 (Bios ver 5.04.48.0056e, Kernel 3.10.62-x86_64byt-g105afb7) . I have also confirmed that the same problem happens on a Lenovo A1010a20 phone also running Android 5.1.
The two horizontal scales look like https://www.machine-dro.co.uk/horizontal...-inch.html (200mm & 300mm length) and the vertical scale looks like https://www.machine-dro.co.uk/digital-sc...?limit=all.
Other observations are that the high value changes by the same value of the base value ie base = 0mm high = -10403.84 base = 47.64 (-47.64 on scale display) high = -10356.20. This is after moving the scale to about 80mm, zeroing the scale then zeroing all axes on the DRO. Y axis readout is inverted.
Connecting the same vertical scale to the Z axis and starting with the scale zeroed at about 35mm,  base  = -32.93, high = 10370.91. Base = 0  & above - TouchDRO display seems more stable.  Z axis was not inverted
I have a 10uF tantalum cap across the scale connector which is soldered to a 4 core (non screened) about 85cm long. The PSU is an 8v stabilised mains supply


Regards
Barry
Reply


Messages In This Thread
X axis not working correctly - by edeeec - 01-03-2017, 09:50 AM
RE: X axis not working correctly - by edeeec - 01-08-2017, 04:56 PM
RE: X axis not working correctly - by Yuriy - 01-10-2017, 03:27 AM
RE: X axis not working correctly - by edeeec - 01-11-2017, 09:41 AM
RE: X axis not working correctly - by edeeec - 01-28-2017, 04:15 PM
RE: X axis not working correctly - by Yuriy - 01-30-2017, 05:41 PM
RE: X axis not working correctly - by edeeec - 02-05-2017, 03:23 PM
RE: X axis not working correctly - by edeeec - 02-23-2017, 08:37 AM
RE: X axis not working correctly - by Yuriy - 02-24-2017, 03:26 PM
RE: X axis not working correctly - by edeeec - 02-25-2017, 03:08 PM
RE: X axis not working correctly - by Yuriy - 02-25-2017, 04:39 PM
RE: X axis not working correctly - by edeeec - 02-27-2017, 08:43 AM
RE: X axis not working correctly - by Yuriy - 02-27-2017, 03:25 PM
RE: X axis not working correctly - by edeeec - 03-11-2017, 06:58 PM
RE: X axis not working correctly - by edeeec - 03-22-2017, 09:53 PM
RE: X axis not working correctly - by Briney Eye - 03-22-2017, 09:59 PM
RE: X axis not working correctly - by heavyg603 - 03-26-2017, 12:59 AM
RE: X axis not working correctly - by Briney Eye - 03-26-2017, 10:58 PM
RE: X axis not working correctly - by keesk - 10-10-2017, 01:04 PM
RE: X axis not working correctly - by Philcobt - 02-26-2018, 11:26 PM
RE: X axis not working correctly - by Yuriy - 02-27-2018, 02:30 AM
RE: X axis not working correctly - by Philcobt - 02-27-2018, 04:05 PM
RE: X axis not working correctly - by qtron - 06-28-2018, 03:44 PM
RE: X axis not working correctly - by qtron - 10-29-2020, 12:27 PM
RE: X axis not working correctly - by Yuriy - 10-29-2020, 05:00 PM
RE: X axis not working correctly - by qtron - 10-30-2020, 01:02 AM

Forum Jump:


Users browsing this thread: 1 Guest(s)