Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird readouts shahe scales
I have been trying to get shahe scales to work. i have both the diy kit and a board i built to use comparators for the signals. however when i open bluetooth serial i get gibberish results. has anyone else experienced this?

Attached Files Thumbnail(s)
I haven't seen this before. If the copyright message wasn't there (i.e. all was jibberish), it would be a mismatch in the BAUD rate beween the MSP430 and the BT module. Since it gets the first part correctly, it has to be something else.
It could be a defect in the bluetooth module,but it aligsn too neatly with the semicolon of the copyright message, which is strange. It has to be something with the MSP430. Grasping at the straws here, but is the part MSP430G2553? I.e. if somehow you got a chip with lower number, it could be a memory overflow.
I can try to help a bit later (in a few days). I'm at a hospital with my wife righ now. If things got well, we will be back home on Sunday.
Thank you
I hope your wife gets better! and thanks for your help. its definitely msp430g2553. i bought a 10 pack of them as im an idiot and managed to hook the polarity backwards on the first instead of spending a few minutes to look for a supply with a matching barrel Jack..... but even before that the touch dro app would connect but then quickly drop the connection. this was with an asus tablet which reading other forums i have picked up a Samsung tab to try again. but it has an extremely old version of Android so finding a custom rom just to upgrade android to even get the playstore has been a pain in the ass. I flashed the mixed scale firmware. Im thinking it read zeros right at first so maybe the chip got corrupted somehow? ill try to flash another tomorrow. Just making sure, these shahe scales are the newer square type displays (bin6?) so would i want to use the newest mixed scale or the igaging firmware that now also says it supports bin6.
Thank you
Just to be clear: the kit ships with the iGaging firmware (V2). It supports BIN6, 21-bit iGaging, and 52-bit iGaging Absolute protocols. In theory "Mixed scale" firmware should work for Shahe scales, but the firmware doesn't handle Shahe "negative" flag correctly. In general, unless you REALLY need it, and know what you are doing, don't use the Mixed Scale version. It's old and needs a lot of love. I just haven't gotten to updating it.
It looks like you are using V2.0, though, at least judging by the first few characters.
If you can email me your PayPal transaction ID, I can send you a new preprogrammed chip HC-05 module to rule those out.
okay i have also picked up a couple hc-05. what needs to be programmed? Can it be done through at commands with an arduino?
i tried flashing two new msp430g2553 boards with the igaging 2.0. tried on both the diy and the one i made. still got the same results.

Attached Files Thumbnail(s)
HC-05 is good to go out of the box.
Honestly, this makes no sense. Now for some reason, you are getting the version marker but not the position readouts. I have not seen this before and can't even think of a mechanism for this to happen. I know this firmware works since I shipped hundreds of boards and kits with it. The file you downloaded is the EXACT binary I flash into them.
If it were a BAUD rate mismatch, everything would be scrambled; memory overflow would crash the chip, so you would get a bit of data and then a reset or junk.
Can you try re-downloading the file from the website and re-flashing it?
Also, just to make sure:
1. What flasher software/hardware are you using?
2. what is the exact command you are running?
3. Are you getting good positive voltage (should be 3.3V)


Actually, it looks like you are getting X0;
Have you tried connecting the scales? With the new firmware, they should be connected to the MCU directly, no comparators, by the way.
okay i have not tried it reconnecting the scales since i reflashed the new chip. this is the igaging 2.00 i am using the launchpad emulation board to flash it with the command line interface. i copied the command per the intructions for flagging. ill try redownloading and recheck the 3.3v

i tried hooking the hc05 up directly on the launchpad. it shows the copyright followed by x0;v11111; thanks for your help

should it make a difference whether or not the scales are actually connected to the readouts?
Hm, so the code works on the LaunchPad but no on the kit board?
What is the supply voltage on the board?

Forum Jump:

Users browsing this thread: 1 Guest(s)