Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lathe DRO: Tool functionality
#1
Hi All,

I have been using the DRO on my lathe, using 2 glass scales and the Tach connected, and the display on a 10" tablet. Using mm settings.
Very usefull sofar.

However, when using the Settings-Tools function, I get a strange error in the DRO App:
  1. I added a tool, give it a name, and a radius offset for the X axis. 
    I am using the Diameter options on the main screen.
  2. I set the X-axis to 'Zero' using the short tab on the display.
    All ok, the reading of the X changes to twice the radius setting of the tool.
  3. When I want to change the tool-offset, and use the "Edit tool" function, I can not change the offset only. The name of the tool is blank, and I need to specify the name again.
    That is strange.
  4. Also when I save the edited tool, the tool offset for X in the tool-list, is multiplied by 1000 or 10000 factor..
    And when I set the X display to zero, it uses this multiplied value as well.

I tested this on 3 display devices, all with the same issue.
I can not imagine no one else has encountered this situation yet?

Thanks for your help,
Frans
Reply
#2
Just bumping my question...
Is no one else having this issue?

I am ok to investigate this myself in more detail, but would need access to the source of the DRO App.. Would that be possible somehow. I am ok to share my finding/results afterwards.
Thanks,
Frans
Reply
#3
While I know you are frustrated with the app, you might not know that Yuriy (the author) has been working on a total re-write.  Check on few of the recent posts where he has responded to issues.

 
Stay tuned ...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)