Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New Ti board - no scale
Hi Thierry, great news that you have made some progress. Strange that they both work when flipped over. I would try swapping again but make sure that both scales are fully connected before powering up the msp430 so it can run through the auto detect cycle.
Hi Norman
I already tried twice but I'll try again tomorrow.
Hi Norman.
No change !!!!
The Y scale (brand new Shahe scale) does not want to be connected to P2.4 and P2.1.
I tried Y scale alone on P2.5 (it works) and P2.4 (it does not work).
X and Y scale (normal connections Y does not work), then inverted (the two scales work).

At a time I had digits from the Y scale, but they did not move accordingly to the scale and stopped moving quickly.

Should I try the Mixed Scale Firmware for MSP430 LaunchPad ?
Hi Thierry, yes you can try using the mixed scale firmware (keep using the separate clock pins, 2.0 & 2.1).

As a test (it will not fix the problem) you could try connecting the new scale to the Z axis pins and see if it works there. You might need to switch to milling machine mode in the settings screen to enable the Z axis in the application. Z data is on 2.3 and Z clock is on 2.2.
Hi Norman.
I tried with the mixed scale firmware : no scale work.
I went back to the iGaging firmware.
I plugged the scale to the Z axis and it works.

That's driving me crazy

Hi Thierry

If I try to summarise:

The new scale:
- Works when connected to the X input on pin 2.5
- Works when connected to the Z input on pin 2.3
- Does not work when connected to the Y input on pin 2.4

The older scale:
- Works when connected to the X input on pin 2.5
- Works when connected to the Y input on pin 2.4

Are all of the above true?

When the new scale is working (on pin 2.5 or 2.3) does the movement of the scale match the change in the reading? (So if you move the scale by 10mm does the display change by 10mm?). When you move the scale, can you get it to display positive or negative numbers?
You summarised well, and what you wrote is the reality.

It happened once that the new scale worked, but the digits moved two or three times and did not match the movement of the scale.

Hi Thierry,

Did the display show + and - values when moved? Perhaps the measurement and the movement of the scale could be fixed by changing the setting of the CPI  value in the Settings screen but this would not fix the issue with the Y input on pin 2.4

I suspect the scale is not 100% compatible with the firmware (perhaps close but not fully compatible) - Yuriy, your thoughts on this would be very welcome.

It looks like there might be a difference in the Y input auto detect cycle too - Yuriy, again your thoughts would be helpful!!
Let's say that the digits showed "10" and when I moved the handle it showed 25 and stopped moving.
I had asked to Shahe manufacture what was the difference between the old and the nex scales, and they said that the only difference was the dispaly.....
Hi Thierry,
Does the Shahe display head from the new unit work with the older scale?
And does the display head from the older unit work with the new scale?
*** You must be sure the power supply feed uses the same pins before trying to swap the units.

Next step might be an oscilloscope to compare the signals....

Forum Jump:

Users browsing this thread: 1 Guest(s)