Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Noise issues
#1
I am having issues with noise while the spindle motor on my mill is running.

I have the igaging adapter board and when I first connected my scales to the board and linked to touchdro, my readings were fairly stable. X almost had no flickering and y and z would jump up and down about .003.

So to try and fix this issue, I tried to follow the post a while back about making the igaging scales more reliable. I electrically isolated the y and z scales from the mill's frame, took all loops out of the cables, and connected the cable shielding to ground on the adapter board side only. I disconnected the x scale completely until I have time to make some plastic mounts to isolate it.

After doing all of this, I tested the setup again and now the problem is worse. The z axis jumps up and down about .001, but the y axis just infinitely decrements any time the spindle motor is running.

I have triple checked to make sure the scale was isolated from the frame, after leaving the read head, the cables are routed in the opposite direction of the spindle motor to try and minimize magnetic interferance. At this point it would be better for me to go back to the way it was when it would jump around .003.

If anyone has any insight on this issue, I would greatly appreciate the help
Reply
#2
First thing I would try would be to plug your device into a different circuit than what your machine is on. Maybe, for testing, run an extension cord from a receptacle that you know is on a different circuit.
Reply
#3
Have you added capacitors to the read heads? A 1uF cap across the power lines inside the read head of the scale cured my jumping problems.
Reply
#4
Hi Folks,
If you have problems with changing readouts (arduino) place a toroid 4C65 in the power line (9 or 12V line) and your problems are gone.

Greetings Jacques
Reply
#5
Thanks Great old one! I actually tried a cap across the power lines on the adapter board yesterday and it improved the problem greatly. I soldered a .1uf cap in the read head today and boom. Problem instantly solved. Even when the scales touch the mill's frame. Thank you everyone for your help!
Reply
#6
Okay, one last problem. I got the caps soldered in all the read heads and connected everything back to the board and y and z are perfect. They don't move no matter what I do to the spindle motor. But now my x scale completely stopped working. It just reads the same number all the time. I tried connecting it to the w block and it works fine. But as soon as I connect it back to the x block it jumps back to that one number and won't move. Nothing is shorted in the read head or anywhere I could find on the board. All connections have continuity except I couldn't check the data screw because I had no idea where that trace ran to. I am not familiar with this microcontroller so if anyone knows any way to troubleshoot this, I'd love the help. Thanks!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)