Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No clock signal (iGaging) on pin 1.7 with v2.0 firmware?
#1
Has anyone else tried v2.0 firmware with iGaging scales? It looks like the clock has been lost from pin 1.7. If I revert back to v1.31 then all is ok.
Am I missing something obvious? Suggestions welcome.
Reply
#2
Hi all,

This info for  the Touchdro adapter board might be the answer:

  "SV1 (on the left) is connected to pin 1.7 that is used for 21-bit clock output in the standard firmware. Since this version provides the clock directly to the relevant pins, P1.7 is currently inactive."
(https://www.yuriystoys.com/2016/01/touch...aging.html)

If the recently posted v2.0 firmware is a direct copy from the Touchdro adapter board unit then perhaps the conclusion is p1.7 is inactive and the v2.0 iGaging firmware is incompatible with iGaging scales when used with the MSP430 Launch pad kit.

Yuriy - can you confirm or correct my theory? Thanks.
Reply
#3
Hi all,

Has anyone else managed to test the v2.0 firmware on the MSP430 Launch Pad with iGaging scales?

Yuriy - your input would be very welcome too.

I'm about to buy 2 more scales - but if iGaging is perhaps not going to be fully supported on a Launch Pad build, then do I need to find a different make (newer Shahe perhaps?).

Thanks.
Reply
#4
Hi all,

Mystery solved thanks to  a pointer from Yuriy, (thanks Yuriy!).

My original Launch Pad build followed these instructions:

https://www.yuriystoys.com/2013/07/launc...tions.html

But the more recent firmware should be wired to this later configuration:

https://www.yuriystoys.com/2014/01/dro-i...sp430.html

As well as using individual clock pins per scale, you should note the W axis data line has moved.

Also worth noting, that if you're looking for it, the clock signal will not be present on the clock lines unless there was a scale connected when the Launch Pad was reset/powered on, (part of the auto scale detect I suspect).

Thanks again to Yuriy for pointing me in the right direction.

Hope this helps others when upgrading the firmware.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)