Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bluetooth data pausing every 4-5 seconds

I've built a Launchpad 430 version of the DRO with micro-usb connections and an HC-06 bluetooth module. Firmware used is the Mixed Scale v1.0. Latest TouchDRO on the play store (i think it's version 2.5.10) on a Nexus 7 2013.

The scales are: ,some sort of iGaging clone?

I can read all the scales correctly, but every 4-5 seconds the scale fails to refresh the reading on screen for a split second (maybe half a second). When the reading continues it's at the correct measurement. So 1, 2, 3, 4, 5, 6, 7, 8 pause 11, 12, 13, 14.

I've installed BlueTerm and can see that every 4-5 seconds the data pauses and then continues.

I've tried resetting/reinstalling the tablet to defaults, so nothing else is installed, i've turned off all sync with Google but i haven't managed to get to the bottom of it. 

I've also tried it on a OnePlus-5T, although its better, there is still a stutter.

One other thing i've just noticed, if i go into the settings menu it disconnects from HC-06 then reconnects when i go back to the program, is that normal?

Any help would be appreciated.

This is very likely a problem with the controller, not the app. The scales you are using are Shahe/iGaging 21-bit version, so you don't need the mixed scale firmware. Basic version will work better, since it's optimized for these scales.
That said, I haven't seen this behavior before, so I don't know what could be causing it.

Disconnects/reconnects are normal and done intentionally
Hi Yuriy,

I was actually using the Basic 1.31, i remember trying the Mixed Scale version but it didn't work.

I'm going to try another bluetooth module to see if that's the problem.

OK, so it looks like it was Android 6.01, or the version i had installed on the tablet. After much frustration I've managed to get an unofficial later version of android installed and things appear to be working as they should.

The Bluetooth connection doesn't even disconnect when entering the menu anymore.

Early days but i think it sorted my problem.


Forum Jump:

Users browsing this thread: 1 Guest(s)