Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help please, can't get a signal from the scale.
#1
I guess it's like the days before satnavs, blokes would never stop and ask for directions or when you buy a new microwave ... you take it out of the box, cast the instructions aside, plug it in and then realise you don't have a clue how to use it.  So you take yourself off with the instructions to a dark corner and hope no one sees you reading them.

Well, I'm afraid I've reached the dark corner point with TouchDRO.  I'm probably on a par with the more intelligent Muppets when it comes to electronics.  I can just about follow a circuit diagram and assemble it but I don't have the foggiest idea what all the components do and how they interact together.  Given that background I've tried to put together a system using a Teclast 11 tablet and an Arduino Uno.

I've had a modicum of success in that the app's on the tablet (I should add tablets and apps are all new to me ... I'm still using Win XP on a 15 year old PC) blue tooth works, I can connect TouchDRO to bluetooth and see the correct data ...X0;Y0;Z0;W0;P0; etc on the tablet when viewing in BlueTerm.

 
What I can't get is any reading from the scale to show in the TouchDRO app.  I currently have one scale set up with a bread board circuit.  The Arduino is powered by a mains to 9v power supply.  I'm using the Arduino firmware DRO V5.11 from http://www.rysium.com/rysium.docs/  and I have a Chinese scale bought from Aliexpress which the advert claimed was a Shahe product typically ...

[Image: 6-Remote-Digital-DRO-Table-Readout-Scale...20x220.jpg]

The business end of this looks for all intents and purposes identical to the AccuRemote and iGaging DigiMag scales you have in the US (I'm UK based).

 
I've checked the 3V and ground at the back of the USB connector in the scale head.  Ground goes to pin 4 not 5 on the socket, but I guess that's intended and I've checked I haven't damaged the scale or reader by reconnecting the original readout and all is fine.
 
So, I'm at a loss ... I've Googled to exhaustion and tried everything within my limited ability to solve the issue so can anyone suggest a solution or additional checks I might try.
 
Thanks in advance for any assistance.
Reply
#2
Try taking the battery out of the scale and run it at 1.5v setting.  I got caught out believing the scale was 3v as it had a lithium cell, everything worked at 1.5v.... Also check your clock and data lines are correct.  I would be interested to hear your results as I am looking for scales as mine don't indicate ± correctly.   Also in the UK.
Reply
#3
Joules ...

I pretty much came to the conclusion that the scale was incompatible, so after more searching I found a thread on one of the model engineering forums where Yuriy had posted that the scales sold by Arc Euro Trade were the same as iGaging scales. So I duly ordered one to give that a try.

All credit to this company, I ordered Friday lunchtime and it was pushed through the letterbox before midday on Saturday ... very impressed. Price wasn't too bad either ... circa £32 inc. shipping for a 150mm scale vs. circa £20 for the Aliexpress version, and it looks to be a far better design internally.

I hooked it up to the Arduino and it seems to work OK. Subsequently I found your post ... https://forum.yuriystoys.com/showthread....790#pid790 which says you are having trouble with them. The set up I have with the Arduino and the firmware version detailed above appears to be accurate to within a thou or so calibrating it on the bench using a caliper and +/- appears to work as it should.

The scale from Arc Euro Trade arrived with a copy of their brochure in which there is a warning printed in red stating that these scales are not suitable for connection to a PC ... didn't see the same warning on their website!

I'll play with the set up a little more, perhaps do a lash up installation on the mill so I can calibrate it more accurately, but so far it looks quite promising. As for the very cheap scale from Aliexpress, I'll probably rig it up on the pillar drill unless I can find anything more useful to do with it.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)