Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ESP32 Bluetooth
Hi all, newbie from UK here - Dave

I am embarking on the challenge of building a Touch DRO adapterĀ based on the ESP32 chipset.
After learning the basics I have (I believe) successfully loaded the latest firmware (v1.6) and on completion, the blue LED flashes but it is not visible via bluetooth on any android device.
The LED flashes fast, for around 3s, pauses for around 0.5s then fast again - rinse and repeat
I have tried power reset etc with no joy.
I then erased the flash and loaded the earlier v1.4 firmware but still same results

any clues????

This adapter is planned for use with glass scalesĀ on my milling machine but at the moment it is just the ESP32 WROOM board (with USB-C connection)

I also intend to build a second adapter for my lathe with iGaging scales using the MSP40/HC-05 setup so any advice with that would also be appreciatedSP4

Thanks in advance
Looks like I have a faulty ESP32 board. I tried a basic Bluetooth test programme via Arduino, that didn't work either.
I ordered another board (really cheap off Amazon with next day delivery).
This time the Arduino programme worked so I flashed the TouchDRO v1.6, and this time success.
I had a small issue with Bluetooth dropping out, but once I powered the board from a wall supply rather than my PC USB socket, all worked well and connected to the TouchDRO App.

Now to build the scale interface circuit.

The MSP40 board should arrive tomorrow, hopefully i can get that working with the HC-05 Blootooth board.....

Further update,

The second board does seem to work but not every time it is powered.
More often than not, on power up, the blue led either flashes fast, or is on for a few seconds, quick flash off, then on again. In both cases, I cannot connect Bluetooth.
Randomly, it will power up correctly, slow blue led flash, I can connect and the TouchDRO App registers and everything is fine (still no scales connected). Once working, it is stable and I have had it connected for a couple of hours with no dropouts.
Bluetooth Serial Teminal app shows a stable string of x0,y0,z0,w0 etc when it is working.

Anyone else had similar and resolved?

I am concerned that it is a power application issue. I am just connecting/disconnecting the USB cable at source (2.1A USB wall supply). I have ordered a switch which I will try to see if that makes any difference.


Forum Jump:

Users browsing this thread: 1 Guest(s)