Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TouchDRO works w/Igaging on Arduino, but not 430G2 Launchpad
I'm having difficulties getting my two rev 1.5 430G2 Launchpads to work with the latest MP430 firmware (v 2.0).

1 Digi-mag Igaging type shahe
3 EZ-View Plus genuine Igaging

2 rev 1.5 MSP-EXP430G2
1 Arduino Uno R2 clone

Bluetooth boards:
2 HC-06
2 H-C05

ver 2.0 Igaging 430 type


clock line (white) to pin 1.7
data line (green) to pin 2.3 (one scale used for test on X)
VDD line (red) to vcc pin (lower right of board)
GND line (black) to gnd pin (lower right of board)

Bluetooth board:
Rx to pin 1.2 (UART)  (I have also tried these two reversed)
Tx to pin 1.1 (UART)
+5v to pin VCC (upper left of board)
GND to GND (upper right of board)

USB phone type battery bank into USB connector on board

430 launchpad board has the ~1 second red led heartbeat after initializing. Bluetooth board fast flashes until connected. Then TouchDRO tablet shows the bluetooth board is connected. Bluetooth board goes to slow flash. Readout numbers show green on the screen, all zeros. With scale disconnected the display is stable for more than 30 seconds. When the scale is attached and the board reset, and the scale is moved by hand, nothing changes on the readout. This happens with both Igaging scale types.

1. opened scale reader case, and verified continuity for each line, as suggested.
2. tried the touchDRO Arduino version, using the same scales and the same bluetooth boards and it works
3. Verified that the scales also work with the Igaging display.
4. Switched around scales, two 430 boards, and the 4 bluetooth boards. No changes.
5. Tried switching TX and Rx k lines on Bluetooth connection

I don't know how else to test to troubleshoot this problem.

Thanks for any help.
Website Issues:

1.) Yuri Toys website downloads page states version 2.0 of firmware is the recommended version.
2.) Following the site instructions, hookup for MSP430 rev 1.5 boards connect pin 1.7 for clock signal for Igaging type scales
3.) Board does not work with this cofiguration.
4.) Hunting for solutions after 2 days of fruitless troubleshooting, I find the TouchDO website downloads page says re. version 2.0: "Note: This firmware outputs scale clock on each clock line as opposed to pin 1.7"
No explanation of what this means.
5.) This note is NOT included on the Yuriy's Toys website downloads page.
6.) There is no Igaging launchpad pin hookup information on the Touch DRO website. Instead there are circular references to hookup that DO NOT include specific board hookup information.

Basic question:

What pin should a MSP430 launchpad board builder use for the Igaging clock signal with ver 2.0 of the firmware, as recommended??

Sorry for the later reply - I've been swamped at work...
Have you seen this:
Thank you
Steve. Does this link hep you at all?
I am fairly new to this but the way I understand it is that each scale has its own data pin and its own clock pin rather than all scales sharing a clock pin. So X, Y and Z will use the pins P2.0, 2.1 and 2.2 while data will be on pins P2.3, 2.4 and 2.5. I could be wrong.
Also look at the comments on the following link, some people talk about different firware flashing methods having an effect.
(04-08-2022, 01:20 AM)Yuriy Wrote: Steve,
Sorry for the later reply - I've been swamped at work...
Have you seen this:
Thank you
Yurly, yes -- that is part of the problem. It says:

"Once you have a working base control circuit, you will need to add the input stage appropriate for your scales and, if needed, a secondary power supply. Build instructions for the most common adapter configurations are linked below.

    DIY DRO Adapter for iGaging and Shahe Scales"

But, If you click on the link it takes you to the build page. At the bottom of the build page it says:

"Data and Clock Pins
Once the power supply lines are connected, connect the Clock and Data lines as described on the scale information page."

But, the scale information page

says nothing about connecting a clock line to the rev. 1.5 Launchpad board. All it does is indicate what clock lines  are available on the scales -- not where the clock line goes on the board Under Version 2.0 of the firmware.

If I connect the clock line to pin 1.7, it doesn't work under the 2.0 rev firmware, because I believe you eliminated that line? Is there somewhere else???

Hi Steve,

You might be past this problem now? But if not, then have you seen this post:

Might give you some pointers.


Forum Jump:

Users browsing this thread: 1 Guest(s)