Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOLVED: Basic controller reads Igaging scale, but Universal does not
(05-28-2018, 04:32 PM)Steve Wrote:
(05-28-2018, 03:52 PM)Yuriy Wrote:
(05-27-2018, 08:43 PM)Steve Wrote: Hello, looking for help on my mixed scale controller build. This thing is driving me crazy!

Voltage Shifter Board:         I did the bare strip board build.
Scales:                               I have an aluminum Digi-mag Igaging type Shahe scale, and a couple of Chinese calipers
TI board:                            EXP430G2 w/ M430G2553 chip
Programmer:                     FET-Pro-430 Software Pkg. - LITE
Firmware:                          DigitalReadout_Universal_V1.0.hex,


If I flash the TI board for Digital Readout Basic Igaging support firmware - (without using the voltage shifter board) and connect the Shahe scale clock line to P 1.7 and the data line to any of 2.3,2.4, 2.5  the bluetooth tablet reads each perfectly.

If I flash the TI board for Digital Readout Universal, and connect the voltage shifter board with the same Shahe scale (data line to P2.5 and clock line to P2.0), nothing changes on the bluetooth tablet when I move the scale.

If I connect a caliper (clock to P2.1, and data line to p 2.4), the same thing happens. No change on the Bluetooth tablet when moved. (However, the caliper's own readout shows correct measurement moves, and that it is properly powered.)

Checked so far:

1.) All wiring has been checked several times.
2.) Voltage to both scales was checked while connected. Shahe is getting 3.5V and caliper is getting 1.5V. This was checked to their individual grounds. Caliper is powered up and shows readings
3.) LM339 pin 3 =3.5v measured against pin 12 (ground)
4.) LM339 pin 6 = 1.7v measured against ground
5.) I replaced the upper LM339. No difference
6.) I have a second identical TI EXP430G2 board. I've substituted that in, and get exactly the same results as the first board.
7.) Running BlueTerm shows good connection and continuous output of x0,y0,z0,w0. Moving the scales makes no change.

I have tried the 1.0 version of the firmware, as well as the 0.3 version. And also both the .txt, and .hex versions.

I can return to Basic igaging mode firmware and the Shahe scale again works fine. Can't test the calipers in this mode. However their readouts still work fine.

Any suggestions? This is really driving me nuts.

Shahe scales require external clock (assuming you are using the original "DigiMag" version) to work. You will need to run a jumper from Pin 1.7 to scale's clock pin. 

Thank you Yuriy.

So that would mean (for X channel Digimag ) and using "Mixed" firmware and voltage converter board, remove the board jumper that goes to P2.0, and reconnect it to p1.7?

No, you need both. The controller still needs to get clock and data in. It uses the pulses on the clock line to read the data line state. Digimag scales get their clock from the display, not the reading head, so they won't push any data. P1.7 is for the scale, but the MCU will still get it through P2.0.

Thank you

Messages In This Thread
RE: Basic controller reads Igaging scale, but Universal does not - by Yuriy - 05-28-2018, 04:41 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)