Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tachometer Issues on iGaging Launchpad Build (a FW bug?)
#1
Hey guys,
This is my first post here.
First of all, a huge, huge thank you to Yuriy! What you have done and shared is just nothing short of amazing. I was in between buying a pre-made board or going the Launchpad route but since I like a challenge (and live in far-away China) I went with the Launchpad DIY option. As an aside, I think Yuriy should have kept a donation button up;-)

But let me get on with it. My build has gone OK. I had some issues getting the FW onto the chip. Mostly because I am a Mac guy who is severely limited once on a PC, but in the end, it worked out. I did have an issue with the bluetooth module but I think it was just a dud. I ordered a new one and it has worked flawlessly. So, did my Shahe scales.

Now, I would love to have a tachometer, too. I have tried different hall effect sensors but I have, what could possibly be, the same issue as have been reported in the past with the DIY Mixed Scales FW - I have a very low readout value. Even when I spin the lathe (or power drill for testing) at high speeds I can't get a higher value on the DRO than approximately 30 RPM...
I have tried pre-built hall effect sensor boards and also some loose 3144 sensors. Some go to from 0V to 3.3V when magnets are sensed, some go the other way around. I have tried them all and they all behave the same once hooked up to the Launchpad - they all give 0-30 RPM values. So, I think they are working and I think the Launchpad is reading them OK but perhaps there is a bug in the firmware...?

I am connecting positive to VCC on the board, ground to ground and the out to P1.4. My firmware is Basic V1.31.

I think I have seen some posts from Yuriy where he says he ironed out a tach bug in the Mixed Scales FW, but perhaps it is present in the Basic firmware?
Does anyone know if I can run the Mixed Scale firmware even though I am only using Shahe/Igaging scales? That could possibly solve the issue. It's just that since getting the FW onto the chip has been the hardest thing in this build, I am hesitant in having to have another go at flashing it...;-)


All best and once again, big cudos to Yuriy!
Reply


Messages In This Thread
Tachometer Issues on iGaging Launchpad Build (a FW bug?) - by GeckoSub - 01-01-2018, 05:03 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)